somemo's diary

プログラマ、雑記、プログラミング関係はLinkから、数式はこっちでまとめていることが多い

【Ruby】バージョンを指定してインストール【gem】

Railsのインストールに失敗していましたが、バージョンを指定することでインストールできました。バージョン指定のコマンドは以下のとおりです。

gem install rails -v=2.3.14

#公式では以下になっています。
#http://rubygems.org/gems/rails/versionsより
gem install rails -v 2.3.14

失敗の原因は、そもそもRuby1.8.7で3.11のRailsをインストールしていたことも原因の一つかなと思います。