somemo programming etc.

プログラマ、雑記、プログラミング関係はLinkから、数式はこっちでまとめていることが多い

【ruby】rdocインストールできない【gem】

前回でようやくrailsインストール準備が完了しました。しかし、rdocがインストールできません・・・

symantec

cacheディレクトリにあるrdoc-3.11.gemを見るとsymantecに怒られているようです。他のgem(http://production.cf.rubygems.org/gems/json-1.6.1.gemなど)は、ダウンロードできます。

rdoc最新のURLはここです。

http://production.cf.rubygems.org/gems/rdoc-3.11.gem

3.10も試してみましたがだめでした。

エラー内容は以下の通りです。

Proxy Encountered Error
Error: Internal proxy error: Unable to scan file due to SCANERROR_MALFORMED_CONTAINER error while scanning file.

rdoc不要の場合

開発環境でrdocが不要でないのでやりたくないですが、下記コマンドでrdocを除外しましたがだめでした。

gem install rails --no-rdoc