somemo programming etc.

プログラマ、雑記、プログラミング関係はLinkから、数式はこっちでまとめていることが多い

【php】json_encodeが使えるバージョン

開発とリリース用のphpのバージョンが違っていて、お客様から不具合があがったことがあったのでメモです。

動くバージョンは、5.2以上です!最近はデザイン面でもajax面でもjQueryを使うことが増え、json形式のデータを扱うことも増えたので覚えておきましょう。特に、CentOSとかちょっとバージョンが古いやつもあるは注意!

バージョンを上げたくないときは、php-pearphp-devel,php-peclインストールを前提に下記コマンドを実行してください。

pecl install json

vi /etc/php.d/json.ini
#extension=json.soを追記する(コメントなし)